Important Action Required : Essential Addons for Elementor critical vulnerability

A vulnerability has been discovered and patched in the Essential Addons for Elementor plugin. All users of this plugin please update to the latest version, 5.7.2, as soon as possible.

For all users of Essential Addons for Elementor, please update to the latest version, 5.7.2, as soon as possible.

On 11th May 2023, the Essential Addons for Elementor, a WordPress plugin with over one million active installations, released a patch for a critical vulnerability that made it possible for any unauthenticated user to reset arbitrary user passwords, including user accounts with administrative-level access. This vulnerability was discovered and responsibly disclosed by security researcher Rafie Muhammed.

You can read more information from the Wordfence blog.

Please remember to always keep your website backed up and your WordPress installation and plugins up to date.

If you think you may have been hacked, or you need help updating your website, get in touch. I’m happy to have a look.

Privacy Settings